Back to overview
Resolved

Service down

May 12, 2026 at 11:30am UTC
Affected services
api.pdmar.com

Resolved
May 12, 2026 at 12:30pm UTC

This incident has been resolved

Created
May 12, 2026 at 11:30am UTC

We are currently investigating this issue.